Antenna Placement
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10231   Accepted: 5051

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

Source

 
 
将每个点拆点
构建二分图
求一下最小边覆盖
最小边覆盖=点数-最大匹配数
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=1001;
int vis[MAXN];
int link[MAXN];
int map[MAXN][MAXN];
int N,M;
bool dfs(int x)
{
    for(int i=1;i<=N*M;i++)
    {
        if(map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!link[i]||dfs(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int belong[MAXN][MAXN];
char a[MAXN][MAXN];
int xx[5]={0,-1,+1,0,0};
int yy[5]={0,0,0,-1,+1};
int main()
{
    #ifdef WIN32
    freopen("a.in","r",stdin);
    #else
    #endif
    int Test;
    scanf("%d",&Test);
    while(Test--)
    {
        memset(link,0,sizeof(link));
        memset(map,0,sizeof(map));
        memset(a,0,sizeof(a));
        scanf("%d%d",&N,&M);
        for(int i=1;i<=N;i++)
            for(int j=1;j<=M;j++)
                belong[i][j]=(i-1)*M+j;
        for(int i=1;i<=N;i++)
            scanf("%s",a[i]+1);
        int tot=0;
        for(int i=1;i<=N;i++)
            for(int j=1;j<=M;j++)
            {
                if(a[i][j]=='*')
                {
                    tot++;
                    for(int k=1;k<=4;k++)
                    {
                        int wx=i+xx[k],wy=j+yy[k];
                        if(wx>=1&&wx<=N&&wy>=1&&wy<=M&&a[wx][wy]=='*')
                            map[ belong[i][j] ][ belong[wx][wy] ]=1;
                    }
                }
            }
    //    for(int i=1;i<=N;i++,puts(""))
      //      for(int j=1;j<=M;j++)
       //         printf("%d  ",belong[i][j]);
        int ans=0;
        for(int i=1;i<=N*M;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ans++;
        }
        printf("%dn",tot-ans/2 );
    }
    return 0;
}

 

 
内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!

相关课程