Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

感觉来到这里都是大佬,现在开始学线段树。压力大。

这道题给我看了几千字情书,才是题目!!!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct data
{
    long long x,y1,k,y2;
};data f[50010];
struct data2
{
    long long l,r,lazy,max1;
}f1[200000];
long long map[50010];
void pushup(int p)
{
    f1[p].max1=max(f1[p<<1].max1,f1[p<<1|1].max1)+f1[p].lazy;
}
void build(long long l,long long r,long long  p)
{
    f1[p].max1=f1[p].lazy=0;
    f1[p].l=map[l];
    f1[p].r=map[r];
    if(r-l==1) return ;
    int mid=(l+r)>>1;
    build(l,mid,p<<1);
    build(mid,r,p<<1|1);
    pushup(p); 
}
bool cmp(data a,data b)
{
    if(a.x!=b.x) return a.x<b.x;
    else return a.k<0;//先扫描k为负数的 
}
void update(long long l1,long long r1,long long k,long long p)
{
    if(f1[p].l>=l1&&f1[p].r<=r1)//当操作区域在当前区域内时 
    {
        f1[p].max1+=k;
        f1[p].lazy+=k;
        return ;
    }
    if(l1<f1[p<<1].r)
        update(l1,min(f1[p<<1].r,r1),k,p<<1);
    if(r1>f1[p<<1|1].l)
        update(max(f1[p<<1|1].l,l1),r1,k,p<<1|1);
    pushup(p);
}
int main()
{
    long long n,w,h,x,y,k;
    while(scanf("%I64d %I64d %I64d", &n, &w, &h) != EOF)
    {
        int step=0,sum=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%I64d%I64d%I64d",&x,&y,&k);
            f[step].x=x;//结构体建矩形 
            f[step].y1=y;
            f[step].y2=y+h;
            f[step++].k=k;
            f[step].x=x+w;
            f[step].y1=y;
            f[step].y2=y+h;
            f[step++].k=-k;
            map[sum++]=y;//离散化 
            map[sum++]=y+h;
        }
        sort(map+1,map+sum);//排序 
        sum=unique(map+1,map+sum)-(map+1);//去重 求元素个数 
        sort(f,f+step,cmp);//离散化数组排序
        build(1,sum,1);
    //    cout<<"sum:"<<sum<<endl;
        long long maxx=0;
        for(int i=0;i<step;i++)
        {
            update(f[i].y1,f[i].y2,f[i].k,1);
            if(f[i].k>0) maxx=max(maxx,f1[1].max1);
        } 
        /*for(int i=1;i<=n;i++) cout<<f1[i].l<<" "<<f1[i].r<<" "<<f1[i].lazy<<endl;
        for(int i=1;i<=sum;i++) cout<<map[i]<<endl;*/
        printf("%I64dn",maxx);
    }    
}

 

内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!

相关课程