POJ 2387 Til the Cows Come Home (图论,最短路径)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

Line 1: Two integers: T and N

Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Http

POJ:https://vjudge.net/problem/POJ-2387

Source

图论,最短路径

解决思路

最短路径,直接用spfa可以解决

代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;

const int maxN=1001;
const int maxM=2001;
const int inf=2147483647;

class Edge
{
public:
    int v,w;
};

int n,m;
vector<Edge> E[maxN];
int Dist[maxN];
queue<int> Q;
bool inqueue[maxN];

int main()
{
    cin>>m>>n;
    for (int i=1;i<=m;i++)
    {
        int u,v,w;
        cin>>u>>v>>w;
        E[u].push_back((Edge){v,w});
        E[v].push_back((Edge){u,w});
    }
    for (int i=1;i<=n;i++)
        Dist[i]=inf;
    memset(inqueue,0,sizeof(inqueue));
    Dist[n]=0;
    inqueue[n]=1;
    Q.push(n);
    do
    {
        int u=Q.front();
        Q.pop();
        inqueue[u]=0;
        for (int i=0;i<E[u].size();i++)
        {
            int v=E[u][i].v;
            int w=E[u][i].w;
            if (Dist[u]+w<Dist[v])
            {
                Dist[v]=Dist[u]+w;
                if (inqueue[v]==0)
                {
                    Q.push(v);
                    inqueue[v]=1;
                }
            }
        }
    }
    while (!Q.empty());
    cout<<Dist[1]<<endl;
    return 0;
}
内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!