1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

算法说明:

不要存储好楼层再计算,不好控制到底是上升还是下降,会得不全分的。

// 1008 Elevator.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include <iostream>
using namespace std;

int main(int argc, char* argv[])
{
    int floor,stay=0;
    int N;
    int i,time=0;
    
    cin >>N;
    for(i=1;i<=N;i++){
        cin >>floor;
        if(stay==floor){
            time+=5;
            continue;
        }else if(floor>stay){
            time+=(floor-stay)*6+5;
        }else{
            time+=(stay-floor)*4+5;
        }
        stay=floor;
    }
    cout << time <<endl;
    return 0;
}

2020考研打卡第十天,你可知道星辰之变,骄阳岂是终点?美好生活等着我们呢zyy&cdl 加油!!!

努力不一定有收获,但是不努力绝对没有收获,天上也没有掉馅饼那么美好的事情,出来混总是要还的。

内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!