题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1002

题目描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目要求:大数加法

思路:就是简单的大数高精而已,且不用压位操作,不值得大费周章的用c去写,直接上BigInteger。

Code:

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner s1=new Scanner (System.in);
        int n;
        n=s1.nextInt();
        for(int i=0;i<n;i++){
            if((i+1) != 1){
                System.out.println();
            }
            BigInteger a,b;
            a=s1.nextBigInteger();
            b=s1.nextBigInteger();
            System.out.println("Case "+(i+1)+":");
            System.out.println(a+" + "+b+" = "+a.add(b));
        }
    }
}
内容来源于网络如有侵权请私信删除

文章来源: 博客园

原文链接: https://www.cnblogs.com/RpgMaker/p/13587694.html

你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!