题面

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have. 

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug. 

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in. 

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

题解

题目大意:
有N1个插座,每个插座可以插一个电器
有N2个电器,每个电器只能够插在对应型号的插座上
有N3种转换器,可以把后面一种插座变成前面那种
问,最少有几个电器不能够插在插座上
题解:
源点向电器连边,容量为1,
电器向对应的插座连边,容量为1
对于转换器,在插座和插座之间连边,容量为INF
最后插座向汇点连边,容量为插座的个数
最后计算最大流即可

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
#define MAX 100000
#define MAXL 500000
#define INF 10000000
map<string,int> cz;//插座
int cnt1,level[MAX],cnt2;
int vis[MAX];
int A[MAX],B[MAX];
int WP,Change,CZ;
int S,T;
struct Line
{
    int v,next,w,fb;
}e[MAXL];
string ss,sss;
int h[MAX],cnt=1;
inline void Add(int u,int v,int w)
{
    e[cnt]=(Line){v,h[u],w,cnt+1};
    h[u]=cnt++;
    e[cnt]=(Line){u,h[v],0,cnt-1};
    h[v]=cnt++;
}
bool BFS()
{
    for(int i=S;i<=T;++i)level[i]=0;
    level[S]=0;
    queue<int> Q;while(!Q.empty())Q.pop();
    Q.push(S);
    level[S]=1;
    while(!Q.empty())
    {
        int u=Q.front();Q.pop();
        for(int i=h[u];i;i=e[i].next)
        {
            int v=e[i].v;
            if(e[i].w&&!level[v])
            {
                level[v]=level[u]+1;
                Q.push(v);
            }
        }
    }
    return level[T];
}
int DFS(int u,int f)
{
    if(u==T||f==0)return f;
    int re=0;
    for(int i=h[u];i;i=e[i].next)
    {
        int v=e[i].v,d;
        if(e[i].w&&level[v]==level[u]+1)
        {
            d=DFS(v,min(f,e[i].w));
            f-=d;re+=d;
            e[i].w-=d;e[e[i].fb].w+=d;
        }
    }
    
    return re;
}
int Dinic()
{
    int re=0;
    while(BFS())
        re+=DFS(S,INF);
    return re;
}
int main()
{
    freopen("POJ1087.in","r",stdin);
    cin>>CZ;
    for(int i=1;i<=CZ;++i)
    {
        cin>>ss;
        if(cz.find(ss)==cz.end())
            cz[ss]=++cnt1;
        vis[cz[ss]]+=1;
    }
    cnt2=cnt1;
    cin>>WP;
    for(int i=1;i<=WP;++i)//连接物品和插座
    {
        cin>>ss>>sss;
        Add(S,i,1);
        if(cz.find(sss)==cz.end())cz[sss]=++cnt1;
        Add(i,WP+cz[sss],1);
    }
    cin>>Change;
    S=0;
    for(int i=1;i<=Change;++i)
    {
        cin>>ss>>sss;
        //Add(S,i,1);
        if(cz.find(ss)==cz.end())cz[ss]=++cnt1;
        if(cz.find(sss)==cz.end())cz[sss]=++cnt1;
        Add(WP+cz[ss],WP+cz[sss],INF);
    }
    T=WP+cnt1+1;
    for(int i=1;i<=cnt2;++i)
        Add(WP+i,T,vis[i]);
    
    printf("%dn",WP-Dinic());
    return 0;
}
内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!