An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题目大意:修复和测试,然后输出结果
题解:并查集的模版题,直接看代码吧
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
using namespace std;
#define PI 3.14159265358979323846264338327950

int father[20010],num;
int p[20010]={0},n;

struct point
{
    double x;
    double y;
}pt[1005];


int find(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find(father[x]);
}

double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

void combine(int a,int b)
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
        father[fa]=fb;
}

int main()
{
    int i,x,y;
    double d;
    char control[2];
    scanf("%d %lf",&n,&d);
    
  
    for(int i=0;i<1005;i++)
        father[i]=i;
    for(int i=1;i<=n;i++)
    {
        scanf("%lf %lf",&pt[i].x,&pt[i].y);
    }
    while(scanf("%s",control)!=EOF)
    {
        if(control[0]=='O')
        {
            scanf("%d",&x);
            p[x]=1;
            for(i=1;i<=n;i++)
            {
                if(dis(pt[i],pt[x])<=d&&p[i]==1)
                    combine(i,x);
            }
            
        }
        if(control[0]=='S')
        {
            scanf("%d%d",&x,&y);
            if(find(x)==find(y))
                printf("SUCCESSn");
            else
                printf("FAILn");
        }
    }
    
    
}

 

内容来源于网络如有侵权请私信删除
你还没有登录,请先登录注册
  • 还没有人评论,欢迎说说您的想法!